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AUTOCAD 3-D BASICS 
 

Course Content 
 

 
AutoCAD 3-D Basics has 8 PDH units and is divided into 10 sections. Step-by-step illustrated 

examples show how to use tools to create all types of three dimensional solid models of machine 

parts and assemblies. 

Note that the first stage in creating many 3-dimensional drawings is a 2-dimensional drawing. 

This course begins with a recap of some of the most useful AutoCAD commands needed to: 

make, save, and print 2-dimensional drawings. 

 

SECTIONS 
1. 3D Solid Model Examples 
2. Menus, Toolbars, and Commands  
3. Dimension Controls 
4. User Coordinate System 
5. Simple 3D Solid Models 
6. Extrusions 
7. Commonly Used Commands 
8. Flat Plate With Five Holes 
9. Generic Hub 
10. Drawing Check List 
11. 3-D Command List 
12. Related Links 
 

The techniques described here include all versions of AutoCAD released 
including releases 14 to 2012.  

The AutoCAD release 2011 manual has over 1000 pages. This lesson has only 87 pages but the 
most used 3-D drawing methods are described, enabling the reader to make all types of three 
dimensional drawings. All versions of AutoCAD lite are used to create 2 dimensional drawings 
only.  

AutoCAD Inventor is: 3D, parametric, and has many more advanced features than regular 
AutoCAD. Please see my course: G280, AutoCAD Inventor - Solid Modeling, Stress and Dynamic 
Analysis. 
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1. 3D SOLID MODEL EXAMPLES 
    Three dimensional AutoCAD drawing commands and tools described in this lesson are 

applicable to the: Mechanical, Structural, Industrial, Chemical, Electrical, Manufacturing, and Civil 

engineering disciplines. 

 
 

PUMP INSTALLATION 
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The pipe spool and pump installation above is 3D solid modeled in AutoCAD. 
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STRUCTURAL STEEL DETAILS 
The 3D structural details help fabricators and construction crews to understand 2D drawings. 
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MACHINE PARTS 
The machine parts above were created using AutoCAD solid modeling. 

 



www.PDHcenter.com                            PDH Course G209                        www.PDHonline.org 
 

 

PIPING ISOMETRIC  
The pipe spool design above is another AutoCAD drawing. 

 
 
2. MENUS, TOOLBARS AND COMMANDS 
Drop Down Menus 
The drop-down menus along the top of the display are shown above and contain all of the 2D and 

3D drawing commands under four headings: 
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Insert, Draw, Dimension, and Modify 
Model View 

The flat metal plate with 5 holes shown above is in the Model View area. 

The Toolbars, described below also contain all AutoCAD commands. 

 

Toolbars AutoCAD release 14 to 2005 

To show the Toolbars shown below select: View > Toolbars > Check: Draw > Modify > 
Dimension > Close. 
Toolbars AutoCAD release 2006 - 2012 

To show Toolbars right click any Drop Down Menu or Toolbar to open a complete list of Toolbars 

and select: Draw > Modify > Dimension > Solids > Solids Editing > View . 
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Quick Key Commands 

Quick Key commands are typed on the Command Line and include:  

                                                 L for Line 

                                                 C for Circle 

                                                 M for move 

                                                 E for Erase 

                                  MI for Mirror 

                                              CP for Copy  
                                                    and are illustrated below. 

FUNCTION KEYS 
The function key f3 is used to toggle Object Snap on and off. 

The function key f7 is used to toggle Grid on and off. 

The function key f8 is used to toggle Ortho on and off. 
The function key f9 is used to toggle Snap on and off to Grid points.  
 
Work Spaces 
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Click on the “Workspace” drop down menu “AutoCAD Classic” and select the desired 
environment. 
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3D Modeling workspace has been selected above. 

 
Right click on any toolbar > Pick desired new toolbar from the list of all toolbars. 
 
Docking Toolbars 
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Dock a toolbar by picking its handle and dragging to the left or right side of the display area as 

shown above. Toolbars may be docked at the bottom and top of the display but should be 

avoided because this practice reduces the already limited height. 
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Pick drop-down menu: Tools > Palettes > Tool Pallets > All Pallets opens as shown below. 

 

 
Draw toolbar 2000 with commands labeled above and Draw toolbar 2012 below. 
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2012 
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 Each icon has a pop-out label describing its purpose. The icons of the most commonly used  

 

2012 
Modify toolbar commands are labeled above. 

 

 2012 
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Dimension toolbar commands are labeled above. 
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Solids toolbar commands are labeled above. 

 
Solids Editing toolbar commands are labeled above. 
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View toolbar commands are labeled above. 

 

 
The Visual Styles toolbar is pictured above. 
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Select the object to change its Visual Style 
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Pick Visual Style “Realistic” 

 
Pick the ByLayer drop down menu to open the Select Color dialog box below. 

 
Change an objects color with the Select Color dialog box shown above. 

Select the object > Select a color > OK 

 

3. DIMENSION CONTROLS 
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This dialog box below opens when: D for Dimension Style Manager is typed on the command 

line. 
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Note: All dimensions are in the X-Y plane. 
Dimension features are adjusted with the Dimension Style Manager dialog box above. 
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Select the Modify… button to obtain the Override Current Style dialog below.  
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Primary Units Tab offers: Scientific, Decimal, Engineering, Architectural, and Fractional 

dimension styles. 
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Text Tab above offers: Text height: .1300 is the normal size when dimensions are inches. Text 

height: 3.3 when dimensions are millimeters. 
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Dimension size can be easily scaled by typing: DIMSCALE on the command line, > Type the new 

scale number > Select menu Dimension > Update > Select all dimensions needing to be 

updated to the new scale. 
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Fit Tab above offers: Text placement and Fine tuning. 

Pick Beside the dimension line and 

Place text manually.
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4. USER COORDINATE SYSTEM (UCS) 
The User Coordinate System commands are used to establish the X-Y, X-Z, and Y-Z plane 
orientations and the Isometric View. 
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SW ISOMETRIC VIEW 
Pick the SW Isometric View icon on the View toolbar as illustrated above. 

Display the X, Y, and  Z Origin UCS as shown above and described below. 

 
 

USER COORDINATE SYSTEM (UCS) 
Select the View drop down menu shown above to view the X, Y, and Z coordinate origin. 
Pick Display > UCS Icon > ON. 
Repeat by picking Display > UCS Icon > On > Origin. 
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5. SIMPLE 3D SOLID MODELS 
Box, Sphere, Cylinder, Cone, Wedge, and Taurus form basic 3D building blocks. Creating, 

modifying, and combining each of them is described below. 
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BOX 
Pick the Box icon on the Solids toolbar. 

Pick the location of the bottom corner of the box that is to be drawn, as shown above. 

Type L for Length in the X direction > 4. 
Type 3 for Width in the Y direction. 
Type 1 for Height in the Z direction. 

Press the Space bar to end this command. 

PLACE UCS ORIGIN 
Pick the Origin UCS icon as shown above. 
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Pick the bottom corner of the Box to place the UCS Origin. 
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HIDE HIDDEN LINES 
Pick the Hidden icon on the Styles toolbar (Shade toolbar on older releases of AutoCAD) to view 

the solid model. 
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Pick the 2D Wireframe icon to restore the background. 

 
COLOR SELECTOR 
Pick the Color Selector drop-down menu as shown here. 
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SELECT COLOR 
Pick the desired Color square in color pallet as shown above. 

Press the Space bar to end this command. 
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SHADE 
Pick the Gouraud Shade icon on the Shade toolbar and all items drawn in Model View will be 

shaded. 
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EXTRUDE FACE 
Select the Modify drop down menu > Solids Editing > Extrude faces. 
Pick the Box top surface edge. 

Type R for Remove and pick the back bottom Box edge as shown above. 

 Press the Space bar to indicate that all surfaces have been selected or removed. 

Type > 1.0 for extrusion height in the Z direction. 

Type the angle of taper > 30 (degrees). 
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Press the Space bar to end this command. 

 

See, “ADD DIMENSIONS” page 28.                 Rev: 15 Mar 08 
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FILLET 
Type F for Fillet. 

Type R for Radius. 

Type > 0.5  
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Pick the Box top surface edge where it shows Fillet above. 

Press the Space bar. 
Type C for Chain 

Pick the 3 remaining top edges. 

Press the Space bar to end this command. 

Select the entire solid and restore the surface color as described in, “SELECT COLOR” above. 
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ROTATE BOX IN THE X-Y PLANE 
Type RO for Rotate. 
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Select the Box shown at the top of the above figure. 

Pick a Base Point about which rotation will take place in the X-Y plane. 

Type R for Radius. 

Type rotation angle > 180 (+180 anticlockwise, -180 clockwise) 

Press the Space bar to end this command. 
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SHELL 
Select the Modify drop down menu > Solids Editing > Shell. 
Select the 3D Solid Box. 
Select the top 2 edges as shown above to Remove Faces. 

Type A to add faces and pick the far corner to restore faces removed by the previous step. 

Press the Space bar. 
Enter shell offset distance or thickness > 0.125. 
Press the Space bar to exit this command. 
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3 POINT UCS ORIGIN 
Place the User Coordinate System, UCS. 

Create the green box: Type: BOX on the command lines. 

Pick the location of the lowest corner. 
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Type: C for Cube > 1 for dimension 

Place the green box at the point on the blue box shell edge where it is to be sliced as shown 

above. 

 Pick the 3 Point UCS Origin icon as indicated above. 

Pick point 1 for Origin. 
Pick point 2 for the X axis. 
Pick point 3 for the Y axis. 
 
SLICE 
Type SL for Slice. 
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Pick cutting plane points 1, 2, and 3. 
Press the Space bar. 
Type B for Both sides to remain after slicing. 

Press the Space bar to end this command. 

Type M for Move. 

Select the left end of the Box. 
Pick any Base point. 
Drag the mouse pointer so that the left end of the box moves to the location shown. 

 
 

ADD DIMENSIONS 
Note: All dimensions are in the X-Y plane on the left side of the green box.  
Use 3 Point UCS to move the X-Y plane to the box right side to dimension the length of the 
box. 
Type OS for Object Snap in the Drafting Settings dialog box pictured below. 
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Now the mouse pointer will snap to: Endpoint, Midpoint, Center, and Intersection. 
Toggle function key f3 until Object Snap is ON within the command line. 
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Pick the Linear Dimension icon as shown above. 

Pick each top corner of the green box, 

Pick the 1.00 inch dimension location. 
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COLOR SELECTOR 
Select the object to be colored. 

Pick the Color Selector drop-down menu. 

SELECT COLOR 
Pick the desired Color square in color pallet as shown above. 

Press the Space bar or pick OK to end this command. 



www.PDHcenter.com                            PDH Course G209                        www.PDHonline.org 
 

© John R. Andrew                                                  Page 31 of 87 

 
 

3D ORBIT 
Right click on any toolbar > Pick “Orbit” from the list of all toolbars. 
Select 3D Orbit as shown above. 

Drag the mouse pointer across the, “orbit circle” until the object has rotated to the desired 

orientation. 

Press the Space bar or press Enter to end this command. 
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CYLINDER 
Pick the Cylinder icon on the Solids toolbar. 

Pick the location of the top center of the cylinder that as shown above. 

Type D for Diameter > 4. 
Type -4 for Height in the negative Z direction. 
Press the Space bar to end this command. 

Diameter Dimension  
Note: All dimensions are in the X-Y plane. 
See the “Add Dimensions” note above. 

Pick the Origin UCS icon, X, Y, and Z arrows, and place them on top of the cylinder.  

Place the X-Y plane on the top of the cylinder by the 3-Point UCS method described under the 

Dimension topic described above. 

Pick the Diameter icon as shown above. 
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Pick any point on the edge of the circular top of the cylinder. 

The 4.00 inch diameter dimension is now placed. 
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Height Dimension 
Repeat the Dimension steps above to place the 4.00 inch height. 

Press the Space bar. 
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MOVE THE 3.00 DIA CYLINDER TO THE CENTER OF THE 4.00 DIA CYLINDER 
Type M for Move. 

Select the 3.00 dia cylinder. 

Press the Spacebar. 
Pick the center of the 3.00 dia cylinder. 

Drag the 3.00 dia cylinder to the center of the 4.00 dia cylinder as shown above. 
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SUBTRACT INNER CYLINDER FROM OUTER 
Type: SU for subtract on the command line. 
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Pick the outer cylinder. 

Press the Space bar. 
Pick the inner cylinder. 

Press the Space bar to end this command. 
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CYLINDER 
Pick the Wedge icon on the Solids toolbar. 

Pick the location of the bottom corner of the wedge as shown above. 

Type L for Length in the X direction > 2. 
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Type 4 for Width in the Y direction. 
Type 1 for Height in the Z direction. 
Press the Space bar to end this command. 

Dimensions 
See the “Add Dimensions” note for cylinders above. 
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CONE 
Pick the Cone icon on the Solids toolbar. 

Pick the location of the bottom center of the cone as shown above. 

Type D for Diameter > 3. 
Type 4 for Height in the Z direction. 
Press the Space bar to end this command. 

Dimensions 
See the “Add Dimensions” note for cylinders above. 
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SPHERE 
Pick the Sphere icon on the Solids toolbar. 
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Pick the location of the center of the sphere as shown above. 

Type D for Diameter > 3 (no dimensions yet). 

Press the Space bar to end this command. 
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TORUS 
Pick the Taurus icon on the Solids toolbar. 

Pick the location of the center of the tours as shown above. 

Type D for Tours Diameter > 4. 
Type D for Tube Diameter > 1. 
Dimensions 
See, “ADD DIMENSIONS” page 28.      Rev. 15Mar08 
All dimensions are in the X-Y plane.            

Pick the, “Wire-frame” icon when dimensioning. 

Pick, “Hidden” icon on the Visual Styles toolbar and move dimensions until visible.  

 
 
COMBINING SOLIDS 
The Camera made from a cylinder, two boxes, and wedge have been Aligned and Moved as 

described below. 
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ALIGN 
Type AL for Align on the command line. 

Press the Space bar. 
Select the objects: Wedge and Box shown above. 

Pick first source point 1. 
Pick first destination point 2. 
Pick second source point 3. 
Pick second destination point 4. 
Pick third source point 5. 
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Pick third destination point 6. 
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MOVE 
The wedge and block are moved to the top center of the camera. 

Type M for Move on the command line. 

Press the Space bar. 
Select the wedge and block. 

Press the Space bar. 
Pick the Mid-point of the upper block as shown above. 

Pick the Mid-point of the top center of the camera. 
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6. EXTRUSIONS 
Commands for making 3D solid model extrusions are described below. 
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EXTRUDE EXAMPLE 
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Step-1 The part shape is drawn in the X-Y plane as illustrated above. 
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POLYLINE 
Step-2 The outline is converted into one continuous line called a Polyline. 

See below. 
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Step-3 Type PE for Polyline Edit as shown above. 

Type M for multiple lines. 

Select objects: 1 found. (Select one line at a time) 

Select objects: Pick upper right corner. Specify opposite corner. 

Select objects: Pick lower left corner. 15 found. 

Select objects: Type R for Remove. 
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Pick the 1.25 diameter circle. 

Remove objects: 1 found, 1 removed, 15 total. 
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EXTRUDE 
Step-4 Type EXT for Extrude on the command line. 

Press the Space bar. 
Pick any point on the continuous outline of the part and the command line will read: 

Select objects: 1 found, as shown above. 

Press the Space bar. 
Specify height of extrusion: Type 3.5 in the Z direction. 

Press the Space bar. 
Specify angle of taper for extrusion <0>:  

Press Space bar to accept the default value of 0 taper. 

Press the Space bar to complete this command. 
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CHAMFER 
Step-5 Type CHA for Chamfer on the command line or pick the Chamfer icon on the Modify 

toolbar shown above. 

Select first line: Pick the top right corner edge. 

Base surface selection ….(will appear on the command line) 

Enter surface selection option <OK>  

Press Space bar to accept the default OK. 
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Specify base surface chamfer distance: Type .75. 
Press Space bar. 
Specify other surface chamfer distance: Type .75. 
Select the top right corner edge. 

Press Space bar. The top right corner is now chamfered as shown above. 

Repeat the CHA command for the top left corner. 

 

SUTRACT 4 HOLES 
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Step-6 Draw circles at the hole locations shown above. 

Extrude each hole circle thru the part. 

Subtract all holes from the part as described in the above, “Subtract Inner Cylinder From 
Outer” note. 

 
 

EXTRUDE PATH 
The 3 dimensional solid model of the process pipe run above was created with the Extrude Path 
command group. 

 
 
PATH 
Step-1 Draw the pipe run path. 
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Type L for Line on the command line. 

Press the Space bar. 
Pick the bottom corner of the cube as the start of the 24.00 inch line shown above. 
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Toggle the f8 key to turn Ortho ON. 
Drag the mouse pointer in the negative X direction. 

Type the length of the line, 24. 
Press the Space bar. 
Drag the mouse pointer in the negative Y direction. 

Type the length of the line, 36. 
Press the Space bar. 
Drag the mouse pointer in the positive X direction. 

Type the length of the line, 48. 
Press the Space bar. 
Drag the mouse pointer in the negative Y direction. 

Type the length of the line, 24. 
Press the Space bar. 
 

 
 
FILLET 
Step-2 Round the corners with fillets. 
Type F for Fillet on the command line. 

Press the Space bar. 
Type R for Radius on the command line. 

Press the Space bar. 
Type 9. 
Press the Space bar. 
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Pick one intersecting line and then the next forming a fillet as shown above. 

Add fillets at the remaining corners. 

 

Step-3 Convert the pipe lines to one continuous Polyline 
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Type PE for Polyline Edit as shown above. 

Press Space bar. 
Type M for multiple lines. 

Press Space bar. 
Select objects: 1 found. (Select one line at a time) 

Select objects: Pick upper right corner.  

Specify opposite corner. (Select more than one line at a time) 

Press Space bar. 
Press Space bar to accept default <Y> (Convert to polylines) 

Type J for Join. 

Press Space bar. 
Press Space bar to accept default Zero fuzz distance. 
Press Space bar to end this command. 
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CIRCLES 
Extrusions are in the Z direction. 
Step-4 Draw the pipe section. 
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Set the X, Y, and Z axes using the UCS 3-Point commands as shown above. 
Type C for Circle on the command line. 

Press the Space bar. 
Pick the location of the center point. 

Press the Space bar. 
Type D for Diameter on the command line. 

Press the Space bar. 
Type 6.07. 

Press the Space bar to repeat the Circle command. 

Repeat the steps above to draw the 6.63 diameter circle. 

 
EXTRUDE PATH CENTERLINE 

 
EXTRUDE PATH – INSIDE PIPE 
Step-5 Extrude the 6.07 inch diameter inside pipe. 
Type EXT for Extrude on the command line. 

Press the Space bar. 
Pick any point on the continuous polyline pipe centerline. 

Press the Space bar. 
Type P for Path of the extrusion in the Z direction. 
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Press the Space bar. 
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Specify the Path Specify angle of taper for extrusion <0>:  

Press Space bar to accept the default value of 0 taper. 

Press the Space bar to end this command. 

 
 

EXTRUDE PATH – OUTSIDE PIPE 
Step-6 Extrude the 6.63 inch diameter outside pipe. 
Type EXT for Extrude on the command line. 

Press the Space bar. 
Pick any point on the continuous polyline pipe centerline. 

Press the Space bar. 
Type P for Path of the extrusion in the Z direction. 

Press the Space bar. 
Specify the Path Specify angle of taper for extrusion <0>:  

Press Space bar to accept the default value of 0 taper. 
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Press the Space bar to end this command. 
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Step-7 Subtract the inner pipe from the outer pipe. 
Type SU for Subtract on the command line. 

Press Space bar. 
Pick the outer pipe. 

Press Space bar. 
Pick the inner pipe. 

Press Space bar. 

 
 

Step-8 Select the color drop down menu. 
Pick Select Color … at the bottom of the color menu. 
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The Select Color dialog box will open as seen below. 
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Step-9 Apply color to the pipe. 
Change the color of the pipe to Grey #9. 

Press the OK button. 
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Step 10 Add flanges and a valve to the pipe run. 
Create the flanges by following the steps below for creating the “Generic Hub”. 

Create the valve by combining: cylinders, a cone, and the Revolved handle formed when making 

the Generic Hub below. 

 

 

 
 
8. 2D DRAWING USED TO CREATE A 3D SOLID 
The 3-dimensional solid model of the flat plate shown above could have been drawn with all 

versions of AutoCAD from release 14 to 2007. 

EXAMPLE-1 
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This flat plate with holes has been chosen to demonstrate some of the most common AutoCAD 

commands used to make many types of 2D and 3D engineering drawings.  
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The 2D Drawing above will be used to create a 3D solid model 
The dimensioned front and side views of the example part are shown above. 

 
 
Step-1 Draw Line A-B  
Open any version of AutoCAD from release 14 to 2007. 
Type the command: L for Line. 

Toggle function key f8 at the top of your keyboard until you see, Ortho on. 

Pick any point A and drag down a short distance. 

Type the distance 1.5 
Press the Spacebar or Enter Key to end the command. 
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Step-2 Draw Line B-C  
Press the Spacebar or Enter Key to repeat the last command. 
Pick point B and drag to the right a short distance. 

Type the distance 2. 
Press the Spacebar or Enter Key to end the command. 

 
 
Step-3 Draw Offset Lines D-D & E-E  
Pick line B-C. 

Type O, for Offset on the command line. 

Type the distance .5. 
Pick line B-C. 

Pick a point above line B-C. 

Pick line A-B. 

Pick a point to the right of line A-B. 

Press the Spacebar. 

 
 
Step-4 Draw Circle F  
Type C for Circle on the command Line. 

Pick the intersection of lines D-D and E-E. 

Type D for Diameter. 
Type .5. 
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Press the Spacebar. 
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Step-5 Change Lines D-D & E-E to Centerlines 

 
Select the Center Line Layer, pictured here. 

Type L on the command Line. 

Draw center line K-K any length. 

Pick the “Paint Brush” icon shown above. 

Pick any point on center line K-K. 

Pick lines D-D & E-E. 

Press the Spacebar. 
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The LTSCALE command is used to change the Line Type Scale as illustrated above. 

 
Step-7 Trim Hidden Lines L & M  
Type TR for Trim on the command Line. 

Select Lines H-G and J-I. 

Pick a point on line L that extends to the right of line J-I. 

Continue picking line segments that need to be trimmed off.  

Press the Spacebar. 
Select the Chamfer icon on the Modify toolbar 
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Type, D for first chamfer distance. 

 Press the Spacebar. 
Type, .188. 
Press the Spacebar. 
Press the Spacebar. (second chamfer distance is same as first) 

Pick line A-B. 
Pick line B-C. 

 
 
Step-8 Mirror About Imaginary Line A-X 
Toggle function key f8 until you see, Ortho on. 

Type MI for Mirror on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Select point A and drag to the right and pick any point X. 
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Press the Spacebar. 

 
 
Step-9 Mirror About Imaginary Line A-X 
Toggle function key f8 until you see, Ortho on. 
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Type MI for Mirror on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Select point C and drag to the right and pick any point Y. 

Press the Spacebar. 

 
 

STEP 10 Add the 4.00 and .25 diameter Dimensions 
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Pick the Linear Dimension icon. 

Pick point P. 
Pick point R. 
Pick the location of the 4.00 dimension as shown above. 

Pick the Diameter icon. 

Pick point a point on the .25 diameter circle. 

Press the Space bar to end this command. 

 

 
 

STEP 11 Add a 2.00 inch Diameter Hole 
Type L for Line 

Pick line mid points A and B. 
Pick line mid points C and D. 
Type C for Circle. 
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Pick the 2.00 circle center at the intersection of A-B & C-D. 

Type D for Diameter. 

Type 2 for diameter Dimension. 

Pick the Diameter dimension icon. 

Pick the dimension location at Φ2.00. 
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STEP 12 Add Dimensions to Complete the 2D Drawing 
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Pick the Linear Dimension icon on the Dimension Toolbar. 
Pick corners P and R. 

Pick the dimension location at 4.000. 

Pick the Diameter icon. 

Pick a point on the circle. 

Pick the dimension location at φ.250. 

Press the Spacebar. 
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STEP 13 Move From 2D to 3D    
Pick the SW Isometric View icon on the View Toolbar. 
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Type, E for Erase. 

Select each dimension and the side view. 

Press the Spacebar. 
All dimensions and the side view of the plate are erased as shown below. 
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STEP 14 Convert the Part Outline to a Polyline  
Type, PE for Polyline Edit. 

Type, M for Multiple Lines. 

Select each line segment forming the part outline. 

Press the Spacebar to accept, convert lines to Polylines. 

Type, J to Join all of the Polylines. 

Press the Spacebar again to say Fuzz Distance Zero, which is zero gap between line ends. 

Press the Spacebar to end the Polyline command. 

The part outline is now one continuous line. 
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STEP 15 Extrude the Part  and the 5 Holes 
Type, EXT for Extrude. 

Select any point on the continuous outline of the part. 

Press the Spacebar, indicating that all items have been selected. 

Type height of extrusion in the Z direction, -.5 (negative .5 inches). 

Press the Spacebar to accept the default of zero taper. 

Press the Spacebar to end this command. 

Repeat the above commands to extrude each of the 5 holes. 

 
 
STEP 16 Subtract the 5 Holes   
Type, SU for Subtract. 

Select any point on the continuous outline of the part. 

Press the Spacebar, indicating that all items have been selected. 

Select any point on each of the 5 holes. 

Press the Spacebar to end this command. 

The five holes are now subtracted as illustrated below. 
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STEP 17 Change the Color of the Part   
Select the flat plate with the mouse pointer. 

Select the Color Selection drop down menu shown above. 

The open Select Color menu is pictured below. 

 
 
STEP 18 Change the Color to Light Grey  
Pick color 9 for light grey. 

Press the Spacebar to end this command. 
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The part is now light grey. 
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STEP 19 Change the Shade to Gouraud 
Pick the Gouraud icon on the Shade Toolbar as illustrated above. 
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The part is now shaded as shown above.  

 
9. GENERIC HUB 
The 3-dimensional solid model of the Generic Hub shown below could be drawn with all versions 

of AutoCAD from release 14 to 2007. 
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GENERIC HUB  

The AutoCAD commands used to make a 3D solid model of the generic hub pictured above will 

be used to demonstrate typical AutoCAD commands. A 2D drawing of the hub will be used to 

generate a 3D solid model. 
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The dimensioned front, side, and section views of the hub are shown above.  

 
Pick drop-down “Layer Menu” above and select CENTER for centerline. 
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Step-1 Draw Lines A-B  and B-C 
Type the command: L for Line. 

Toggle function key f8 at the top of your keyboard until you see, Ortho on. 

Pick any point A and drag down a short distance. 

Type the distance 5. 
Press the Spacebar or  Enter Key to end the command. 
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Step-2 Draw Center Lines A-E & C-D 

Toggle function key f8 until you see, Ortho on. 

Type MI for Mirror on the command Line. 

Select line A-B. 
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Select point B and drag to the right and pick point C. 

Repeat above steps to obtain line B-D by mirroring line B-C about line A-B. 

Press the Spacebar. 

 
 
Step-3 Draw 4 Circles 
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Type C for Circle on the command Line. 

Pick center point at B. 

Type D for Diameter. 

Type .75 for the inner circle. 

Press the Spacebar or Enter Key to repeat the command. 

Type D for Diameter. 

Type 1.5 for the next circle. 

Press the Spacebar. 
Repeat the above 3 steps for the remaining 3 and 4.5 diameter circles. 

 
 
Step-4 Project the Side View Construction Lines 
Type L for Line on the command Line. 

Pick point F above the 4.5 diameter circle and drag down to G below the circle. 

Press the Spacebar to exit the Line command. 
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Type O for Offset on the command Line. 

Type distance, .75. 

Pick line F-G. 
Pick any point to the right side of line F-G to create line H-I. 
Pick line H-I. 
Pick any point to the right side of line H-I to create line H-J. 

Press the Spacebar. 
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Type TR for Trim on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Pick line segments to be removed by trimming to obtain the side view below. 

Press the Spacebar. 

 
 
Step-5 Trim the Side View Construction Lines 
Trim the side view construction lines as shown above. 

 
 
Step-6 Add Fillets to the Side View  

© John R. Andrew                                                  Page 70 of 87 

Type F for Fillet on the command Line. 
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Type R for radius. 

Type .125 for the dimension. 

Pick 2 lines intersecting at a corner to form a fillet. 

Press the Spacebar to repeat the Fillet command at each rounded corner. 

Type L for Line on the command Line. 

Pick point H and drag down to L. 

Type F for Fillet on the command Line. 

Pick lines L-F and L-H intersecting at L to form a fillet. 

Press the Spacebar to exit the command. 

 
 
Step-7 Add the first 0.375 inch Diameter Bolt Hole  
Type C for Circle on the command Line. 

© John R. Andrew                                                  Page 71 of 87 

Pick the center point for the .375 inch diameter circle shown above. 

Type D for diameter. 

Type .375 for the dimension. 

Press the Spacebar to exit the command. 



www.PDHcenter.com                            PDH Course G209                        www.PDHonline.org 
 

 
 
Step-8 Add the Bolt Hole Circle to the Front View  
Type AR for Array on the command line and the dialog box below will appear. 

 
Pick Polar Array. 
Pick Select objects. 
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Select the 0.375 diameter circle in the drawing. 
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Pick Center Point. 
Select the center point of the bolt circle on the drawing. 

Pick OK. 

 
 
Step-9 Project the first 0.375 inch Diameter Bolt Hole to the Side View 
Type L for Line on the command Line. 

Pick the center point for the .375 inch diameter circle shown above. 

Drag the center line beyond the side view of the hub as shown above. 
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Press the Spacebar to repeat the command. 

Draw the upper and lower, hole projection lines. 

Press the Spacebar. 
Type TR for Trim on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Pick line segments to be removed by trimming to obtain the side view below. 

Press the Spacebar. 
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Step-10 Mirror Upper Hole About Center Line 3-4 
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Toggle function key f8 until you see, Ortho on. 

Type MI for Mirror on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Select point 3 and drag to the right and pick point 4. 

Press the Spacebar. 
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Step-11 Add Dimensions to Complete the Drawing 
Pick the Linear Dimension icon on the Dimension Toolbar. 
Pick side view upper corners to obtain the 1.500 & 0.750 dimensions. 

Pick the Diameter icon. 

Pick a point on one circle and place the diameter dimension. 

Repeat the step above to dimension the remaining diameters. 

Pick the Quick Leader icon and draw the Section A-A view arrows. 
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Press the Spacebar. 
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Step-12 Add Hatching to the Sectioned Side View 
Type BHATCH for Boundary Hatch on the command line and the dialog box above will appear. 

Select Pick Points and pick the inside area points to be hatched. 

Press the Spacebar. 
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Pick OK. 
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Step-13 Select the View Toolbar & Pick the SW Isometric View 
The SW Isometric View of the Hub will be seen as shown above. 

Select the Top View to return to the AutoCAD 2-dimensional zone. 
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Press the Spacebar. 
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Step-14 Erase One Half of the Hub and Place a Cube as Shown 
Type E for Erase and pick all lines to be erased, leaving one half of the Hub as seen above. 

Select the Solids Toolbar and pick the Box icon. 

Pick the location of the bottom left corner of the Box. 
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Type: C for Cube > .5 for length. 

Press the Spacebar. 
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Step-15 Set the New User Coordinate System (UCS)  
Select the UCS Toolbar. 

Pick the 3 Point UCS icon. 

Pick the new: Origin O, X corner, Y corner, as illustrated above. 

 
 
Step-16 The New UCS is Set and Reset. 
Left: The 3 Point UCS has been set with the X-Y plane on the Box bottom. 
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Right: The 3 Point UCS has been set with the X-Y plane on the Box left side. 
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Step-17 Set the New UCS Origin 
The new User Coordinate Origin is shown above with the X-Y Plane on the box bottom. 

 
 
Step-19 Convert Hub Half Section Line Segments to a Continuous Polyline 
Type PE for Polyline Edit. 

Type M for Multiple lines. 

Select the Hub line segments shown dashed here. 

Press the Spacebar to indicate all lines have been selected. 

Press the Spacebar to accept the default Y for Yes join line segments. 
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Type J for Join the line segments. 
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Press the Spacebar to accept default Fuzz distance of 0.000. 

Press the Spacebar to end this command. 

 
 
Step-20 Revolve Hub Half Section to Create the 3-D Solid Model 
Type REV for Revolve. 

Select the Hub Polyline shown dashed in Step-18. 

Press the Spacebar to indicate the continuous Polyline has been selected. 

Define axis of revolution by picking A then B. 
Press the Spacebar accept the default 360 degrees of rotation. 
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=  
 
Step-21 3D Wire Frame 
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Select the Shade toolbar and pick the Wire Frame icon as illustrated. 
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Step-22 3D Hidden Lines 
Select the Shade toolbar and pick the Hidden lines icon. 



www.PDHcenter.com                            PDH Course G209                        www.PDHonline.org 
 

© John R. Andrew                                                  Page 84 of 87 

 
 
Step-23 3D Gouraud Shaded 
Select the Shade toolbar and pick the Gouraud Shaded icon. 

 
 
10. DRAWING CHECK LIST 
Every completed drawing should be checked by the originator and an independent Checker 

before being released to a Client. See the sample drawing check list below: 

Name: _________________________ Date: __________________________ 
    

A DWG NO:________________________  COMMENTS: 
B DIMENSIONS:   
1 Units: Inch or Metric   
2 Overall Height, Width, Length   
3 Zero Datum's    
4 Hole Locations, Sizes & Shapes   
5 All Features Dimensioned   
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6 Decimal Places are a Minimum   
7 Dimensions are Not Crowded   
8 Tolerances are Indicated   
    

C VIEWS:   
9 Orthographic Projection   
10 Outline of Parts are 0.7 Line weight   
11 All Other Lines are 0.3 Line weight   
12 Section & Detail Views Required?    

    
D NOTES:   
13 Material?   
14 Pre-finish Treatment?   
14 Finish?   
16 Hardware, Nearside or Far Side?   
17 How Many: Holes, Hardware?   
18 Shipping Instructions Required?   
19 Description of All Revisions   

    
E FORMAT:   
20 Template: "A", "B", "C", "D", "E"   
21 Part Name and Number   
22 Revision Letter or Number   
23 Drawn By: Initials & Date   
24 Scale   
25 Drawing File Path   

    
F ANALYSIS:   
26 Fit:  Interference With Adjacent Parts    
27 Form:     
28 Function  
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29 Tolerances   
30 Manufacturer's Part Selection    

 
 
11. 3-D AutoCAD COMMAND LIST  
A list of the most commonly used AutoCAD commands are given below. 

CHK  
 Toolbars Rt Key Toolbars > Views > UCS > Solids  
 Object Snap  F3 OS OSnap On / Off 
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 Iso Plane  F5  Top > Right > Left 
 Ortho  F8  On / Off 
 Snap  F9  On / Off 
    
 Arc A Start + Peak + End or Start + Center + Angle 
 Array AR Rectangular or Polar, Offsets, Select Objects 
 Boundary Hatch BH Scale (1.00)> Angle (0) > Pick Point > OK 
 Hatch Edit HE Pick Hatch > Edit 
 Chamfer CHA Dist 1 > Dist 2 
 Circle C Pick Center > D > (2.5) 
 Copy CP  Select Objects > Pick Base Point > Pick End Point 
 Dimension Style D  Dim Manager > Modify > Primary Units > Text > Fit 
 Ellipse EL Pick Major Diameter > Pick Minor Radius 
 Extend EX Pick Boundary > Pick Lines to Extend 
 Fillet F R > (0) > Pick 2 Lines to Intersect 
 Extrude EXT Select Objects > Height or Path 
 Isometric SNAP S > I > (.5) > OK,      F5 > Top Plane > Right > Left 
 Drawing Limits LIMITS Specify Lower Left Corner > Upper Right Corner 
 Slice SL Pick 3 Points > Both 
 Subtract SU Pick large object > Pick small objects 
 Line L Pick Start > Pick End 
 Mirror MI Pick Objects > Pick 2 Points on Mirror Line 
 Move M  Select Objects > Pick Start > Pick End 
 Offset O Enter offset > Pick Line or Object > Pick Side 
 Object Snap OS End Point > Center > Intersect 
 Stretch S Cross Select > Pick Start Point > End Point 
 Trim TR Select Cut Lines > Pick Lines to Trim 
 User Coord Sys UCS Origin > 3 Point 
 Undo U  
 Union UNI Select Objects > OK 
 Zoom All Z > A  
 Zoom Window Z > W Pick Window Corner > Pick Opposite Corner 
 Pan P Pick Window Start > Pick Window End 
 Plot ctrl + P Plot Device > Plot Settings > Pick Window  
 Text Single Line DT Pick Location > Text Height > Angle > (Type Text) 
 Text Multiline T Pick 1st Corner > Opp Corner > (Type Text) 
 Text Edit ED Pick Text > Edit 
 Text Symbols  (Degree= %%D) (Dia= %%C)  (+/- = %%P) 
 Polyline PL Pick Start Point > Pick Several Points Along Line 
 Polyline Edit PE Pick Polyline > Width > (.2) > Fit > (Smoothes Line) 
 Block B Select Objects > Base Point > Name > OK 
 Wblock WB Select Objects > Pick Point > Browse > Name > OK 
 Insert I 
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Browse > Select Block 
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External 

Reference  XR Xref-Manager > Attach > File Path to Drawing 
Attribute 

Definition ATT Pick Insert Point > Tag > Prompt > Value > Wblock  
 Pick Attribute Block > Edit Attribute Edit ATE  

 
 
12. RELATED LINKS 
The AutoCAD home page at: www.autocad.com. 

www.uspto.govThe United States Patent and Trademark Office Home Page at 
Provides links to information about all aspects pertaining to invention patents. 
 

 
This is the end of the AutoCAD 3-D Basics course. 

Please attempt the quiz. 
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