
 

An Approved Continuing Education Provider 

 

PDHonline Course G206 (6 PDH) 

 

 

 AUTOCAD 2-D BASICS  

AutoCAD 2019 TO 2023 

 
 
 
 

 

John R. Andrew, P.E. 

 

 

 

 

 

 

PDH Center 
 

2410 Dakota Lakes Drive 
Herndon, VA 20171-2995 

 
Phone: 703-478-6833   
www.PDHonline.com 

www.PDHcenter.org  

http://www.pdhonline.com/
http://www.pdhcenter.org/


www.PDHcenter.org                        PDHonline Course G206                        www.PDHonline.com 
 

© John R. Andrew                                                  Page 2 of 103 

 

 

 

 

 

    

AUTOCAD 2-D BASICS 

Course Content 

 

 

AutoCAD 2-D Basics is divided into 10 sections. Step-by-step illustrated examples show how to 

use tools to create all types of two dimensional engineering diagrams and drawings. 

The lesson material below applies to all releases of AutoCAD from version 14 to 2014. 

It is not necessary to have AutoCAD to study this lesson. 

The AutoCAD drawing commands and tools described in this lesson are applicable to the: 

Mechanical, Structural, Industrial, Chemical, Electrical, and Civil engineering disciplines. 

 

 

CONTENTS 

1. AutoCAD Drawing Examples 

2. AutoCAD Toolbars  

3. Common AutoCAD Commands 

4. Flat Plate With Four Holes 

5. Generic Hub 

6. Bill of Materials 

7. Dimensional & Geometrical Tolerances 

8. Model Space and Layout 

9. Drawing Check List 

10. 2-D AutoCAD Command List 

11.Related Links 
 
 

The AutoCAD and AutoCAD LT release 2021 manual has over 806 pages.  

 

This lesson has only 98 pages but the most used drawing methods are described, enabling the 

reader to make all types of two dimensional engineering diagrams and drawings. 
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1. AutoCAD DRAWING EXAMPLES 

 

 

Building Plan 

 

Building Plan 
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AutoCAD DRAWING EXAMPLES 

 

 

 

FLOW DIAGRAM 

The flow diagram above was created using AutoCAD. 

 

  

 

 

 

 

 

 

http://www.pdhcenter.org/
http://www.pdhonline.com/


www.PDHcenter.org                        PDHonline Course G206                        www.PDHonline.com 
 

© John R. Andrew                                                  Page 5 of 103 

 

    

EQUIPMENT INSTALLATION 

The piping equipment layout above is an AutoCAD drawing. 

 

 

 

MANUFACTURING DRAWING 
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STEEL FLOOR 

The steel floor above was designed using AutoCAD. 
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PROCESS PIPING SPOOL 

 

 

MACHINED PART EXAMPLE 
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ELECTRICAL CONTROL DIAGRAM 

The electrical control diagram above is an AutoCAD drawing. 

 

 

 

Toggle “Command Line” with:   Ctrl key and 9 
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AUTOCAD 2019 to 2022 
 

 
 

Open AutoCAD 

 

   
 

Select “Open Folder” > Select a Folder 
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Select “Recent” for a list of new drawings. 
 
 
 
 

 
 

Recent drawing selected and opened. 
 
 
 

RECTANGLE 
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Draw an 8” by 4” Rectangle 
 

Pres Function Key F8 to draw horizontal or vertical lines. 

Type L for Line command or select the “Line” tool from the toolbar. 

Pick start point > drag line > pick line end point. 

 
 
 

 
 

Type L > Space bar or 

Select Line tool > Enter 

Press function key F8 for horizontal and vertical lines. 

Pick top line start point left end > 

Drag line right > Type 8 > Enter. 
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Drag down > Type 4 > Drag left > Type 8 > drag up to top left corner. 
 
 

Draw a new rectangle with the rectangle tool. 
 

                   
                                                              

                                         
 
Select > Rectangle Tool > Rectangle > Pick a point and drag a rectangle > Type 8,4 > Enter 
 

Rectangle dimensions are 8.000” long and 4.000” wide. 

 

 

 

Pick automatic dimension tool > 
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Pick left side > Pick dimension location >  

Pick top side > Pick dimension location. 

Dimensions 4.000 and 8.000 inches are added to the drawing. 

 
 
 
 
 
 
 
 

GRID 

 
 

Press funtion key F7 to add or remove dsplay grid. 
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DIMENSION UNITS 
 

 
 

Type D > Enter 
 

or 
 

Type D on the command line for the “Dimension Style Manager”. 

 

Select “Modify”. 
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Select Unit Format “Architectural” drop down menu. 

 

 
 

Select Fraction Format feet and inches  0’.0”  
 
 

 
Dimension units are now changed to Architectural. 

 

MOVE 
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Select Move or 

Type M > Enter > Pick point at top right > Select the rectangle > Enter 

 

 

 

Pick a base point > Drag rectangle to new location >  

Pick new location point > Enter. 

 

ZOOM VIEW 

Roll mouse wheel toward you to Zoom Out. 

Opposite to Zoom in. 

PAN 

Hold mouse wheel down and drag to move drawing. 
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 Type D > Enter > Select > Modify 

 

 
 

Edit arrow size >  
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Edit text size >  
 

 
 

Rectangle is 4” x 8”. 
 
 

 
 

Stretch Command > Type S > Enter or Space bar >  

Pick top right > Release mouse button > Drag bottom left > 

Pick any base point > drag right > 

Type > 1.5 > Space Bar  

 

s  
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The rectangle length is “Stretched” > 8” to 9 1/2” > 1.5 inches longer. 
 

 
 

Erase an Area Example 
 
 

  >>>    
 

Drag select area to be erased:   Drawing after erase. 

Type > E > Space Bar > Pick bottom right >  

Drag to top left > Space Bar or Enter > Green area is erased. 

4” dimension remains. 
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Draw W12x40 steel beam section. 
 
 

   
 

Draw beam flange 8.000” x 0.515 with Rectangle Tool. 

 

 

 

Select Centerline tool >  

Pick beam flange side > Pick opposite side > Enter 
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Draw beam web 10.870” x 0.295” with Rectangle Tool. 

Beam section height is 11.9”                 

Web Height is 10.87, thickness is 0.290”. 

11.9 - .515 - .515 = 10.87” 

 

 

Select > Rectangle Tool > Rectangle > 

Pick a point and drag a rectangle > Type 8,0.515> Enter 

Rectangle dimensions are 8.000” long and 0.515” wide. 
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OBJECT SNAP 

 

Type OS > Enter 

Set > Endpoint > Midpoint > Center > Intersection > Apparent intersection > OK 

 
 

Move web to beam top flange as shown above. 

Type M > Space bar > Select web > Pick web top center >  

Drag to flange bottom center. 
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          e  
 

Object Snap type OS > Enter > Object Snap On 

Mirror type  MI  > Select top flange > 

Pick web vertical line center > 

Drag right > OK 

 

 

 

Bottom flange is a mirror copy of top flange. 
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Trim line and lines to be cut.   

Type Trim or TR > Space bar >  

Select lines to be trimmed >  

 
 

 
 

Lines have been trimmed. 
 
 

          
          

Explode 11.899” dimension X > Select dimension > Enter. 

Edit  ED > Enter > Pick 11.899” dimension > Type 11.9” > Enter 

http://www.pdhcenter.org/
http://www.pdhonline.com/


www.PDHcenter.org                        PDHonline Course G206                        www.PDHonline.com 
 

© John R. Andrew                                                  Page 25 of 103 

   
 

FILLET 

        
 

Type F > Space Bar > Type R > Type 0.5 > Space Bar > 

Pick a line > Pick joining line > Space Bar OR Enter. 

Fillet with radius 0.5” is created. 

 
TEXT 

               
 

Select > A Text > A Multiline Text >  

     
Pick upper left point > Drag a text box to lower left > Pick point 

 

 
Type text  
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Drag a rectangle over text to select it > Type > Scale > 

Pick a base point > Type > 4 > Enter 

Type M for Move > Enter > Pick a point in text > Drag text to new location. 

 

MOVE OBJECT TO X-Y ORIGIN 

    

 

Type  M > Select object > 
 
 

   
 

Pick point on object > Drag mouse pointer to X-Y Origin > Pick Origin.  
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START A NEW DRAWING 

 

   
 

Select top left A > Template >  

 

 

Select Open >  

   

Save As > Drawing with no template. 
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OPEN AN EXISTING DRAWING 

 

Select Drawing > S-103 CLEANROOM 

 

 

Save As > Drawing with template. 
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Mouse right click in the drawing area. 

 

Select > Options 

  

 
 

Select > “Drafting”. 
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Select > “Selection”. 
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Select “Display” > Colors… > 
 

 
 

Select “Color” > Drop down menu > 
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Select “White” > 
 

 
Select “Apply and Close” > OK 
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AutoCAD background is now white. 

 

 

 

 

2. AutoCAD 2019 to 2022 TOOLBARS 

 

                    

                                 Draw                                                                  Mofify 

 

                                       

                                             Annotation                        Match Properties 

 

These four “Toolbars” are commonly used to make AutoCAD drawings. 
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3. AutoCAD 2010 to 2018 TOOLBARS  

 

Docking Toolbars 

Dock a toolbar by picking its handle and dragging to the left or right side of the display area as 

shown. Toolbars may be docked at the bottom and top of the display but should be avoided 

because this practice reduces the already limited height. 

 

 

Draw 

 

 

Modify 
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Dimensions 

 

4. COMMON AutoCAD COMMANDS 

                   

 

The LTSCALE command is used to change the Line Type Scale as illustrated above. 

 

This is the end of Section 2. AutoCAD Toolbars 
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LINE COMMAND 

 

 

Pres function Key F8 to draw horizontal or vertical lines. 

Type L for Line command or select the “Line” tool from the toolbar. 

Pick start point > drag line > pick line end point. 

 

             

  DIMENSIONS 

                                                                      

Select Dimension tool > Pick line > Place dimension 
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Toggle function key f8 at the top of your keyboard until the command line is, <Ortho on>  

Pick any point and drag a short distance to the right. 

Type the distance 2. 

Drag a short distance up. 

Type the distance 1. 

Select Linear tool > Pick two ends of angled line > Place dimension 

 

 

SAVE A DRAWING 

 

 

 

Select drop-down menu: A > Save As > 

 

 

The Save Drawing As dialog box above opens. 

Type the File name of the drawing > Practice Drawing >  

Select an existing folder or create a new folder. 

Select: Save. 
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OBJECT SNAP 

 

 

 

 

The upper dimension above was placed by picking near to corners A & B and snapping 

automatically to the ends of line A-B with snap turned on followed by picking the location of the 

3.00.   

 

Select the function key f3 to toggle Object Snap ON and Off 

 

When adding the dimension to line A-B the mouse pointer will snap to the line intersections at A 

and B when the mouse pointer hovers near A or B. 

 

The mouse pointer picks selected points near the line intersections at C and D when Object Snap 

is OFF as shown above. 

 

The lower dimension above was placed by picking near to corners D & C with snap turned off 

followed by picking the location of the 2.79.   
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OBJECT SNAP DIALOG BOX  

 

Type OS > Enter to open this dialog box. 

Check > Endpoint > Midpoint > Center > Intersection > Apparent intersection > OK 

 

Function key F3 also actives the Object Snap command. 

 

 

The line D-E was drawn by picking near to D the mid-point of line B-C and dragging to point E. 

Because Object Snap was ON the line snapped to D. 
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GRID 

 

Type Grid or press F7 for Grid. 

GRID Snap Control > F9 toggle Snap to ON or OFF 

                   

                                   Grid On                     Type > M > Select Triangle > Pick corner > Enter 

 

                                              Drag triangle corner point to a grid corner. 

 

LAYERS and LINE TYPES  

                   

Properties 

Select > Default > Drop Down Menu 

Select > Continuos  
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Select > By Layer > CONTINUOS > L > Pick a point > Drag right > Type 7 > Enter 

 

Select > By Layer > CENTER > L > Pick a point > Drag right > Type 7 > Enter 

 

Changing Center Lines  

                                       

Select > Match Properties > Pick > Center Line > Pick lines to be changed 
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CIRCLE 

 

 

Select > Circle Tool > Center Diameter > Pick a point in the display area. 

GRID Control > F9 toggle Snap to ON or OFF 

 

       

Drag Mouse > Pick a point >    Type > 2 > Enter              Dimension Tool > 2.00 

 

 

    

Select Rectangle Tool > Type > 0,0 > Enter > 4,8 > Enter        Draw  0.75 diameter circle. 

Rectangle corner is at the “Origin 0,0” 
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                   Type M > Select circle center > Enter > Drag circle to a corner. 

 

 

 

                                                 Circle is at a corner of the rectangle. 

                                                 Press function keey F8 > Toggle > Ortho on 

 

 

                                                    

Type M > Select circle > Drag left > Type 0.75 > Enter  

                                                            Type M > Select circle > Drag up > Type 0.75 > Enter  
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Mirror bottom right circle. 

Type MI > selct bottom right circle > Enter > Pick center of side > Drag left > Enter 

 

 

Mirror two right circles. 

Type MI > Drag selct two right circles > Enter > Pick center of top side > Drag down > Enter 

 

 

 

Center Mark Tool 
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LINETYPES 

                 

    Select either “By Layer” >  Select “Other” >  Linetype Manager opens > Select “Load” 

 

   

     Ctrl key > Pick desired linetypes > OK                      Select > Reload all selected linetypes > OK 

 

Select a centerline > in the Command Line   

Type LTSCALE in the Command Line. 

   

Enter a new scale factor > 3 > OK 

 

                               New centerline scale. 
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Select “Match Properties” > Pick the centerline above 

         

Paint lines to be changed to centerlines. 

 

Select > Annotate  > Select > Center Mark > Pick each circle.  

 

Drag circle center lines as shown. 

 

                                                              

       Select > Dimension Tool             Pick > Circle > Enter                     Select > Trim tool 
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TRIM 

Draw upper and lower horizontal extension lines. 

Add one vertical line between these two lines. 

Make a copy of the vertical line (OFFSET 0.5 inches)  

Select lines to be trimed > Drag select Green Area > Type “Trim” in Command Line  > Enter > 

Pick lines to be trimed. 

 

Right side view of part is created by orthograpghic projection. 

 

Fully dimensioned part with right side view lines ater trimed. 

http://www.pdhcenter.org/
http://www.pdhonline.com/


www.PDHcenter.org                        PDHonline Course G206                        www.PDHonline.com 
 

© John R. Andrew                                                  Page 48 of 103 

 

NOTE 

 

 

Type T for Text in the Command Line at display bottom, and the, “Text Formatting” dialog box 

above will open. 

 

Enter text as shown in the example above. 

 

ROTATE 

 

 

Select the Rotate icon on the Modify toolbar or type RO 

Pick line A-B. 

Pick base point at end A. 

Type angle, 30. 

Press the Spacebar to end the command. 

+30 rotates 30 degrees anticlockwise. 

-30 rotates 30 degrees clockwise. 
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To Draw a Line at an Angle 

Type L for Line. 

Pick any point A and drag a short distance to the right as shown by the dashed line above. 

Type: 3 @ <-15 

Press the Spacebar to end the command. 

f8, Ortho may be on or off. 

3 is distance, @ makes A the start point, < indicates angle, -15 means 15 degrees anti-clockwise 

from horizontal. 

COPY 

 

Select the Copy icon on the Modify toolbar or type CP 

Pick line A-B. 

Press the Spacebar. 

Drag to a point above line A-B. 

Type distance 1. 

Press the Spacebar to end the command. 

 

OFFSET 

 

 

Select the Offset icon on the Modify toolbar or type O 
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Type the distance 1. 

Pick line A-B. 

Pick any point above A-B 

Press the Spacebar to end the command. 

 

MOVE 

 

 

Select the Move icon on the Modify toolbar or type M 

Pick line A-B. 

Press the Spacebar. 

Drag to a point above line A-B. 

Type distance 1. 

Press the Spacebar to end the command. 

 

 

MIRROR 

 

 

Select the Mirror icon on the Modify toolbar or type Mi 

Pick line A-B. 

Press the Spacebar. 

Pick the C end of the centerline and drag to the B end. 

Press the Spacebar to end the command. 
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FILLET & CHAMFER 

 

 

Select the Fillet icon on the Modify toolbar or type F 

Type R for Radius. 

Type .5. 

Pick the horizontal and vertical lines. 

Press the Spacebar to end the command. 

Select the Radius Dimension icon on the Dimension toolbar 

Pick a point on the fillet. 

Pick the location of the R.50 dimension as shown above. 

 

Select the Chamfer icon on the Modify toolbar or type CHA 

Type, D for first chamfer distance. 

 Press the Spacebar. 

Type, .19. 

Press the Spacebar. 

Press the Spacebar. (second chamfer distance is same as first) 

Pick line A-B. 

Pick line B-C. 

Pick the Linear Dimension icon on the Dimension Toolbar. 

Pick the corners of the 0.19 inch chamfer as shown above.  
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Pick the chamfer dimension location. 

Press the Spacebar. 

 

EDIT DIMENSIONS 

 

Type > ED > Enter > Pick > Dimension > Edit dimension 

        

Type, ED for Edit. 

 

Pick the 0.19 dimension…………..see the “Text Formatting” dialog above. 

Type, x 45%%D as shown here. 

Select, OK. 

 

TRIM 

 

Select the Trim icon or type TR 

Pick “Cut Line” D-C. 

Pick the ends of the vertical and horizontal lines to be removed. 
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Press the Spacebar to end the command. 

 

 

ARRAY - POLAR 

     

 

Select the Array icon or type AR 

 

Pick Polar Array. 

Pick Select objects. 

Select the 0.46 inch diameter circle in the drawing. 

Pick Center Point. 

Select the center point of the 2.28 inch diameter bolt circle on the drawing. 

Pick OK. 

NOTE: Rectangular array may be selected. 

 

SCALE 

 

 

http://www.pdhcenter.org/
http://www.pdhonline.com/


www.PDHcenter.org                        PDHonline Course G206                        www.PDHonline.com 
 

© John R. Andrew                                                  Page 54 of 103 

Select the Scale icon on the Modify toolbar or type AR 

Select Objects by picking point 1 and drag to point 2, as illustrated above. 

Press the Spacebar. 

Specify base point by picking the lower left corner of the triangle. 

Specify scale factor by typing 2, for example. 

Press the Spacebar to end the command. 

 

 

STRETCH 

 

 

 

Select the Stretch icon on the Modify toolbar or type S 

The Stretch command is used to extend or reduce the length of a drawn object. 

Select Objects by picking point 1 and drag to point 2, as illustrated above. 

This type of selection is called a Crossing Window. 

Press the Spacebar. 

Toggle function key f8 at the top of your keyboard until you see, Ortho on. 

Specify base point by picking near to the 2. 

Drag to the right and type distance 1 or drag to left and type distance 1. 

The 2.00 inch dimension becomes 3.00 inches or the 2.00 dimension becomes 1.00 inch. 

Press the Spacebar to end the command. 
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ERASE 

 

Select the Erase icon on the Modify toolbar or type E 

Select Objects by picking point 1 and drag to point 2, as illustrated above. 

This type of selection is called a Crossing Window. 

Press the Spacebar. 

 

LIMITS - TO CHANGE DRAWING AREA 

 

Select > View > UCS Icon 

 

Type > Limits > Enter > 0,0 > Enter 
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To Increase the Display Area 

Type Limits on the command line. 

Press the SPACE BAR to accept: < 0, 0 > as the lower left corner of the display. 

Type: 200’, c 200’ on the command line to change the upper right corner. 

 

DIMENSION SCALE 

 

 

 

To Increase the Dimension Scale 

Type DIMSCALE on the command line. 

The present Dimension Scale is 1.0. 

Change it by typing: 1.5 

Select the whole drawing by dragging the mouse pointer from A to B as shown below. 

Pick drop-down menu: Dimension > Update. 

Press the SPACE BAR to end this command. 
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The dimension scale has been increased from 1.0 to 1.5 above. 

 

TANGENT 
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Drawing the 2 Fillets with 1.625” Radius in the figure below. 

Type OS for Object Snap on the command line. 

Step-1: Pick Clear All 

Step-2: Pick the Tangent check box > OK 

Drawing the 2 Fillets with 1.625” Radius (Continued) 

Draw the two 1.625 inch radii by following the 4 steps illustrated above. 

 

CIRCLE > TAN, TAN, RADIUS 
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Drawing the 2 Arcs with 4.750” Radius 

Pick drop-down menu: Draw > Circle > Tan, Tan, Radius 

Pick point A 

Pick point B 

Type: 4.75 for Radius 

Pick point C 

Pick point D 

Trim the 4.750” diameter circles  

Type: TR for Trim 

Pick the 4.000” dia and 2.000” dia circles 

Pick any point in the top half of the 4.750” radius circle 

Repeat the Trim command on the bottom 4.750” radius circle 

 

 

 

 

Finished Pivot Link drawing with title. 
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WBLOCKS 

Write Blocks 

 

 

 

 

Make the electrical circuit drawing above.  

“Motor Circuit 203” using WBLOCKS.  

See “Electrical Symbols” below. 
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ELECTRICAL SYMBOLS 

1. Open any AutoCAD drawing. The electrical symbols drawing above is for illustration purposes. 
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2. Type: WBLOCK in the Command line in AutoCAD. 

3. Pick: Pick point in the Write Block dialog box. 

4. Pick any point inside the Disconnect symbol. 

5. Pick: Select objects in the Write Block dialog box. 

6. Select the highlighted area. 

 

7. Pick the Browse button with 3 dots. 

8. Browse until you find the drawing folder. 

9. Change the title from: new block.dwg to DISCONNECT.dwg 

10. Press OK. 
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11. Open a blank title-block template as shown above. 

 

 

12. Select drop-down menu: Insert > Block.  

13. The Insert dialog box shown above will open. 

14. Pick: Browse and select the DISCONNECT drawing file in your folder. 

15. Pick: OK. 
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16. Pick a point for the DISCONNECT block on the right side of the template as shown above. 

17. Repeat the above steps for each Electrical Symbol needed to complete the: MOTOR CIRUIT 

203 drawing. 

 

This is the end of Section 3. Common AutoCAD Commands 

 

 

FLAT PLATE WITH FOUR HOLES 

 

 

The 3-dimensional solid model of a flat plate shown above could be drawn with all versions of 

AutoCAD from release 14 to 2007. 

EXAMPLE-1 

The flat plate with four holes illustrated above has been chosen to demonstrate some of the most 

common AutoCAD commands used to make many types of engineering drawings.  
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The dimensioned front and side views of the example part are shown above. 

 

 

Step-1 Draw Line A-B  

Open AutoCAD. 

Type on the command: L for Line. 

Toggle function key F8 at the top of your keyboard until you see, Ortho on. 

Pick any point A and drag down a short distance. 

Type the distance 1.5 

Press the Spacebar or Enter Key to end the command. 

 

 

Step-2 Draw Line B-C  

Press the Spacebar or Enter Key to repeat the last command. 

Pick any point B and drag to the right a short distance. 

Type the distance 2. 

Press the Spacebar or Enter Key to end the command. 

 

 

Step-3 Draw Offset Lines D-D & E-E  

Pick line B-C. 

Type O, for Offset on the command line. 

Type the distance .5. 
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Pick line B-C. 

Pick a point above line B-C. 

Pick line A-B. 

Pick a point to the right of line A-B. 

Press the Spacebar. 

 

 

Step-4 Draw Circle F  

Type C for Circle on the command Line. 

Pick the intersection of lines D-D and E-E. 

Type D for Diameter. 

Type .5. 

Press the Spacebar. 

 

Step-5 Change Lines D-D & E-E to Centerlines 

LAYERS and LINE TYPES – ACAD 2019 
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Select > Continuos drop down menu > Other > Enter 

 

CENTER 2 > OK 

 

 

Select > By Layer > CONTINUOS > L > Pick a point > Drag right > Type 7 > Enter 

 

Select > By Layer > CENTER > L > Pick a point > Drag right > Type 7 > Enter 

 

Select the Center Line Layer, pictured here. 

Type L on the command Line. 

Draw center line K-K any length. 

Pick the “Paint Brush” icon shown above. 

Pick any point on center line K-K. 

Pick lines D-D & E-E. 

Press the Spacebar. 

LAYERS and LINE TYPES – ACAD 2020 
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Select > BYLAYER > Drag drop down to > CENTERX2 > OK 

 

 

Select > Bylayer > Drag drop down to > CENTERX2 > OK 

Select > Red 

Type > L > Pick a point > Drag right > Pick a point > Enter 
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Step-6 Draw Hidden Lines L & M  

 

Select the Hidden Line Layer, pictured here. 

Type L on the command Line. 

Pick the intersection of line E-E and the top of circle F. 

Draw hidden line L any length. 

Pick the intersection of line E-E and the bottom of circle F. 

Draw hidden line M any length. 

Press the Spacebar. 

 

 

Step-7 Trim Hidden Lines L & M  

Type TR for Trim on the command Line. 

Select Lines H-G and J-I. 

Pick a point on line L that extends to the right of line J-I. 

Continue picking line segments that need to be trimmed off.  

Press the Spacebar. 

Select the Chamfer icon on the Modify toolbar 

Type, D for first chamfer distance. 

 Press the Spacebar. 

Type, .188. 
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Press the Spacebar. 

Press the Spacebar. (second chamfer distance is same as first) 

Pick line A-B. 

Pick line B-C. 

 

 

Step-8 Mirror About Imaginary Line A-X 

Toggle function key f8 until you see, Ortho on. 

Type MI for Mirror on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Select point A and drag to the right and pick any point X. 

Press the Spacebar. 

 

Step-9 Mirror About Imaginary Line A-X 

Toggle function key f8 until you see, Ortho on. 

Type MI for Mirror on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Select point C and drag to the right and pick any point Y. 

Press the Spacebar. 
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STEP 10 Add Dimensions to Complete the Drawing 

Pick the Linear Dimension icon on the Dimension Toolbar. 

Pick corners P and R. 

Pick the dimension location at 4.000. 

Pick the Diameter icon. 

Pick a point on the circle. 

Pick the dimension location at φ.250. 

Press the Spacebar. 

This is the end of Section 4. Flat Plate With Four Holes 

 

 

GENERIC HUB 

The 3-dimensional solid model of the part shown above could be drawn with all versions of 
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AutoCAD from release 14 to 2007. 

 

EXAMPLE-2 

The AutoCAD commands used to make a dimensioned engineering drawing of generic hub 

pictured above demonstrate more AutoCAD commands.  

Open any version of AutoCAD. 

 

 

The dimensioned front, side, and section views of the hub are shown above.  

 

 

Step-1 Draw Lines A-B  and B-C 

Type the command: L for Line. 

Toggle function key f8 at the top of your keyboard until you see, Ortho on. 
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Pick any point A and drag down a short distance. 

Type the distance 5. 

Press the Spacebar or Enter Key to end the command. 

 

 

Step-2 Draw Center Lines A-E & C-D 

Toggle function key f8 until you see, Ortho on. 

Type MI for Mirror on the command Line. 

Select line A-B. 

Select point B and drag to the right and pick point C. 

Repeat above steps to obtain line B-D by mirroring line B-C about line A-B. 

Press the Spacebar. 

 

Step-3 Draw 4 Circles 

Type C for Circle on the command Line. 

Pick center point at B. 

Type D for Diameter. 
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Type .75 for the inner circle. 

Press the Spacebar or Enter Key to repeat the command. 

Type D for Diameter. 

Type 1.5 for the next circle. 

Press the Spacebar. 

Repeat the above 3 steps for the remaining 3 and 4.5 diameter circles. 

 

 

Step-4 Project the Side View Construction Lines 

Type L for Line on the command Line. 

Pick point F above the 4.5 diameter circle and drag down to G below the circle. 

Press the Spacebar to exit the Line command. 

Type O for Offset on the command Line. 

Type distance, .75. 

Pick line F-G. 

Pick any point to the right side of line F-G to create line H-I. 

Pick line H-I. 

Pick any point to the right side of line H-I to create line H-J. 

Press the Spacebar. 

Type TR for Trim on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Pick line segments to be removed by trimming to obtain the side view below. 
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Press the Spacebar. 

 

 

Step-5 Trim the Side View Construction Lines 

Trim the side view construction lines as shown above. 

 

 

Step-6 Add Fillets to the Side View  

Type F for Fillet on the command Line. 

Type R for radius. 

Type .125 for the dimension. 

Pick 2 lines intersecting at a corner to form a fillet. 
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Press the Spacebar to repeat the Fillet command at each rounded corner. 

Type L for Line on the command Line. 

Pick point H and drag down to L. 

Type F for Fillet on the command Line. 

Pick lines L-F and L-H intersecting at L to form a fillet. 

Press the Spacebar to exit the command. 

 

Step-7 Add the first 0.375 inch Diameter Bolt Hole  

Type C for Circle on the command Line. 

Pick the center point for the .375 inch diameter circle shown above. 

Type D for diameter. 

Type .375 for the dimension. 

Press the Spacebar to exit the command.  

ARRAY 
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Step-9 Project the first 0.375 inch Diameter Bolt Hole to the Side View 

Type L for Line on the command Line. 

Pick the center point for the .375 inch diameter circle shown above. 

Drag the center line beyond the side view of the hub as shown above. 

Press the Spacebar to repeat the command. 

Draw the upper and lower, hole projection lines. 
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Press the Spacebar. 

Type TR for Trim on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Pick line segments to be removed by trimming to obtain the side view below. 

Press the Spacebar. 

 

 

 

 

 

Step-10 Mirror Upper Hole About Center Line 3-4 

Toggle function key f8 until you see, Ortho on. 

Type MI for Mirror on the command Line. 

Select the object by picking point 1 and dragging to point 2. 

Select point 3 and drag to the right and pick point 4. 

Press the Spacebar. 
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Step-11 Add Dimensions to Complete the Drawing 

Pick the Linear Dimension icon on the Dimension Toolbar. 

Pick side view upper corners to obtain the 1.500 & 0.750 dimensions. 

Pick the Diameter icon. 

Pick a point on one circle and place the diameter dimension. 

Repeat the step above to dimension the remaining diameters. 

Pick the Quick Leader icon and draw the Section A-A view arrows. 

Press the Spacebar. 

 

HATCH 
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Type > H > Pick internal point > OK 

                                            

 

 

Step-12 Add Hatching to the Sectioned Side View 

Type > H > Pick internal point > OK 

Pick OK. 

This is the end of Section 5. Generic Hub 

 

 

 

 

BILL OF MATERIALS 
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Select > Annotate > Table 
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Select > Table > Columns > 5 Rows > 6 > OK 

 

 

Pick top left table location point > Enter 

 

 

Type > BILL OF MATERIALS > Enter 

 

 

Type > 1 > Enter 

 

 

Type > 2-3-4-5-6 > Enter 
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Select table top left corner. 

 

Select > Alignment toolbar > Middle Center 

 

 

Pick table “A” column > Enter 
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Pick table column “C” >  

 

 

 

Select > Annotate > Pick top left corner of table > Delete Colums(s) > Column E> Enter 

 

 

Column E is deleted. 

 

 

Pick table cell B3  > Type 2 > Enter 

 

 

Complete Bill of Materials 
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DIMENSIONS & GEOMETRIC TOLERANCES 

 
 
JIG PLATE EXAMPLE 

  
 

1. Draw the jig plate outline:    

Select > Rectangle > Pick a point > Drag a rectangle > 10.203,12.090 > Enter 
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2. Add locator holes: A, B, and C, having a 0.6000 nominal diameter. Adding +/-0.0005 inch 
tolerance is described below. 
 
3. Now draw the support holes: D, E, and F also of 0.6000 nominal diameter. 
 
4. Move the “User Coordinate System” (UCS) origin to the bottom left corner of the jig plate 

base, as seen above, by selecting the following commands: 
 

Old versions of AutoCAD 
Pick drop down menu: View > Toolbar > UCS 

D 
 

 

 
 
5. Locate a new position for the User Coordinate System UCS origin. 
 

Type > UCS > Pick bottom left corner of plate. 

 
The normal location of the origin is at x = 0 and y = 0 at the bottom left corner of the display. 
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Type > D > Enter 
 

 
 

Pick > Modify 
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Set Primary Units to Decimal > 0.0000 
 

 
 

Select > Tolerances > None > Limits 
 

 
 

Type Upper Value > 0.0003 > OK > Close 
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Select > Linear > Ordinate 
 
 

            
 
Origin dimensions must be edited. 
 
Type > ED > Select upper/lower dimensions > Edit > 0.0000 > Enter or OK 
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6. Set the Support Hole Dimension Units and Limit Dimensions shown above 

 
 
7. Dimension the A, B, C, D and F hole diameters with  
Limit tolerances of +0.0005 and 0.0000. 
 
 

 
 
 
 
8. Dimension the A, B and C positions in the jig plate with  
Deviation tolerances of +0.0005 and -0.0005. 
 
9. Dimension the D, E and F positions in the jig plate with 
Limit tolerances of +0.0010 and -0.0000. 
 
On the AutoCAD command line type: D for dimension > M for modify > Primary units > 0.0000 > 
Tolerances > Method > Deviation > Upper value > 0.0003 > Lower value > 0.0000. 
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PRINTING A DRAWING IN MODEL SPACE 

 

Select drop-down menus: File > Print >  

 

The, “Plot – Model” dialog box opens as pictured below. 

 

 

 

Set Paper Size > Tabloid (11” x 17”) > OK 
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Type > Drawing File Name > S-103 CLEANROOM > Save 
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AUTOCAD GEOMETRIC TOLERANCE MENUS 
 

 
 

 
 
OBJECTIVE 
 
A flat top surface and a perpendicular hole are required in the metal plate above. 
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The standard symbols for, “Geometric Tolerances” shown above are generated by AutoCAD. 

 
Type > Tolerance > Geometric Tolerances dialog box opens as below: 
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2. Type A as Datum Identifier as above. 

 
 

 
 
 

2. Place the A in a box, at datum plane, drawn by you as shown above. 

 

 
 

 
4. Pick drop down menu again: Dimension > Tolerance … 
 
5. Pick the Perpendicular to symbol: Symbol > ┴  
 
6. Select the diameter symbol: Ø  

 
7. Type the tolerance: 0.001  

 
8. Type A under “Datum 1, as shown above. 

 

http://www.pdhcenter.org/
http://www.pdhonline.com/


www.PDHcenter.org                        PDHonline Course G206                        www.PDHonline.com 
 

© John R. Andrew                                                  Page 97 of 103 

9. Create the “Flatness” symbol also following the steps above. 

 
 

CREATE LEADER ARROW 
10. Type, “LEAD” on the command line > Pick arrow point location > Drag to Geometric tolerance 

box corner to create a leader arrow. 
 
NOTE: 
It is recommended that you use the MLEADER command to create multiline text with leader 

arrows. 
 

This is the end of Section 7. Dimensional Tolerance. 
 
 
8. MODEL SPACE AND LAYOUT 
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The ANSI D template title block is magnified in the view above. 

 

The template revision list is located in the top right corner shown here. 
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Hydraulic Circuit Diagram Example 

The Hydraulic Circuit diagram above is drawn in the Model tab area, as seen above. 

The ANSI D template title block came from the Select template dialog box described above and 

is in the Layout area and ANSI D Title Block replaces the name normally found on the Layout 

tab. 

 

 

 

 

The ANSI D template title block came from the Select template dialog box and is in the Layout 

tab area as seen above. 
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Keeping in the Layout tab area, type MV for Model View on the command line. 

Pick point 1 with the curser and drag to point 2. 

The drawing in the Model View is scaled and copied into the Layout area automatically as 

illustrated below. 
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The process piping drawing above is automatically scaled by AutoCAD to fit inside the “Layout” 

selected area as shown above. The drawing scale is changed but dimensions do not change 

when a drawing or diagram is transferred from Model View to the Layout area. 

 

DO NOT DRAW OR DIMENSION IN LAYOUT 

Do not add lines or dimensions to a drawing in the Layout area! 

Any changes to a drawing should be done in Model Space because the drawings in Layout 

have been scaled and dimensions added will not be correct. 

 

This is the end of Section 8. Model Space and Layout 

 

DRAWING CHECK LIST 

Every completed drawing should be checked by the originator and an independent Checker 

before being released to a Client. See the sample drawing check list below: 

Name: _________________________ Date: __________________________ 

    

A DWG NO:________________________  COMMENTS: 

B DIMENSIONS:   

1 Units: Inch or Metric   

2 Overall Height, Width, Length   

3 Zero Datum's    

4 Hole Locations, Sizes & Shapes   

5 All Features Dimensioned   

6 Decimal Places are a Minimum   

7 Dimensions are Not Crowded   

8 Tolerances are Indicated   

    

C VIEWS:   

9 Orthographic Projection   

10 Outline of Parts are 0.7 Line weight   

11 All Other Lines are 0.3 Line weight   

12 Section & Detail Views Required?    

    

D NOTES:   

13 Material?   

14 Pre-finish Treatment?   

14 Finish?   

16 Hardware, Nearside or Far Side?   
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17 How Many: Holes, Hardware?   

18 Shipping Instructions Required?   

19 Description of All Revisions   

    

E FORMAT:   

20 Template: "A", "B", "C", "D", "E"   

21 Part Name and Number   

22 Revision Letter or Number   

23 Drawn By: Initials & Date   

24 Scale   

25 Drawing File Path   

    

F ANALYSIS:   

26 Fit:  Interference With Adjacent Parts    

27 Form:     

28 Function   

29 Tolerances   

30 Manufacturer's Part Selection   
 

 

This is the end of Section 9. Drawing Check List 

 

 

 

10. 2-D AutoCAD COMMAND LIST  

A list of the most commonly used AutoCAD commands are given below. 

CHK   

 Toolbars Key View > Toolbars > Views > UCS > Solids  

 Object Snap  F3 OS OSnap On / Off 

 

Isometric Plane  
F5  Top > Right > Left 

   

Grid  F7        
Ortho  F8  

On / Off 
On / Off 

 Snap  F9  On / Off 

    

 Arc A Start + Peak + End or Start + Center + Angle 

 Array AR Rectangular or Polar, Offsets, Select Objects 

 Boundary Hatch BH Scale (1.00)> Angle (0) > Pick Point > OK 

 Hatch Edit HE Pick Hatch > Edit 

 Chamfer CHA Dist 1 > Dist 2 

 Circle C Pick Center > D > (2.5) 

 Copy CP  Select Objects > Pick Base Point > Pick End Point 

 Dimension Style D  Dim Manager > Modify > Primary Units > Text > Fit 
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 Ellipse EL Pick Major Diameter > Pick Minor Radius 

 Extend EX Pick Boundary > Pick Lines to Extend 

 Fillet F R > (0) > Pick 2 Lines to Intersect 

 Isometric SNAP S > I > (.5) > OK,      F5 > Top Plane > Right > Left 

 Drawing Limits 
LIMIT
S Specify Lower Left Corner > Upper Right Corner 

 Line L Pick Start > Pick End 

 Mirror MI Pick Objects > Pick 2 Points on Mirror Line 

 Move M  Select Objects > Pick Start > Pick End 

 Offset O Enter offset > Pick Line or Object > Pick Side 

 Object Snap OS End Point > Center > Intersect 

 Stretch S Cross Select > Pick Start Point > End Point 

 Trim TR Select Cut Lines > Pick Lines to Trim 

 Undo U  

 Zoom All Z > A  

 Zoom Window Z > W Pick Window Corner > Pick Opposite Corner 

 Pan P Pick Window Start > Pick Window End 

 Plot 
ctrl + 
P Plot Device > Plot Settings > Pick Window  

 Text Single Line DT Pick Location > Text Height > Angle > (Type Text) 

 Text Multiline T Pick 1st Corner > Opp Corner > (Type Text) 

 Text Edit ED Pick Text > Edit 

 Text Symbols  (Degree= %%D) (Dia= %%C)  (+/- = %%P) 

 Polyline PL Pick Start Point > Pick Several Points Along Line 

 Polyline Edit PE Pick Polyline > Width > (.2) > Fit > (Smoothes Line) 

 Block B Select Objects > Base Point > Name > OK 

 Wblock WB Select Objects > Pick Point > Browse > Name > OK 

 Insert I Browse > Select Block 

 

External 
Reference  XR Xref-Manager > Attach > File Path to Drawing 

 

Attribute 
Definition ATT Pick Insert Point > Tag > Prompt > Value > Wblock 

 Attribute Edit ATE Pick Attribute Block > Edit 
 

 

This is the end of Section 10.  2-D AutoCAD Command List 

 

11. RELATED LINKS 

The AutoCAD home page at: www.autocad.com. 

The United States Patent and Trademark Office Home Page at www.uspto.gov 
Provides links to information about all aspects pertaining to invention patents. 
 

This is the end of the AutoCAD 2-D Basics course. 

Please attempt the quiz. 
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